Abrupt ending of the simulation without error message of charged PE deposition

log.lammps (207 KB)
density_n_1_50in_0.3.txt (263.8 KB)
I ran a simulation of charged PE deposition on a charged substrate. The system did not encounter any stability issues when I ran the simulation for longer runtimes(10^6) for various charges on the substrate(0.05,0.1,0.2). When I raised the charge on each atom of the substrate to 0.3. The simulation abruptly after considerable run time without error. I ran all these simulations on a windows system parallelly with 8 mpi*1 openmp way. I have attached the output file that I want and the corresponding log file for reference. can someone remark on the issue?


It is impossible to assess what is happening from the files you provide. When LAMMPS stops with a (local) error message, the log file will not get completed and depending on the boundary conditions (e.g. running in parallel on a cluster) will have unwritten buffers (even if they are synced by LAMMPS before exiting) due to the semantics of networked file systems.

So you would need to capture and review the stdout/stderr output. Batch systems usually store them (unless that is disabled with the submission settings). When you run interactively, you can redirect either to a different file or both to the same. The stderr output usually contains the most important information, and that will by default go to the console (but with MPI there may be trouble, depending on the MPI library). So if that is not available for some reason, it may be necessary to try the same simulation with only a single MPI rank (and using OpenMP parallelization, if necessary) on a local machine interactively.