bond atom missing in image check

Dear all,
I am running in NPT ensemble for 300 molecules of ionic liquid with AMber force field. I ran for a small number of steps about 50 microseconds and then I wanted to use atom positions in this state which seems to be equilibrated state for next simulations. I used positions in .xyz file of dump command and substitute them in the data file. First I ran it serial and the warning of bond/angle/dihedral extent > half of periodic box length showed up and after that error of bond atom missing error occurred. In the parallel simulation, the simulation was exited with the error of bond atom missing in image check. Also, I tried using restart, but it exited with the error of did not assign all restart atoms correctly, and I even used remap command but it did not work.
All the bonded and nonbonded energy are in good agreement with the article data.
what is wrong?

Just tell me, if I run for more timestep I can use .xyz coordinations or restart. Because actually, I did not exit the simulation in the parallel simulation on my computer whenever internet is disconnected tthe simulation would be exited. This is the third time that I am going near 100 microsecond and simulation exits. Please help me, so I can finish simulation for 1 nanoseconds.
Best regards

No. What probably goes wrong is that an xyz file does not store box images, so when LAMMPS tries to reconstruct the actual position of atoms that are straddled across the periodic boundary it cannot do so. You need the periodic images. If you want to resume from a dump file, you need to also dump the periodic images. Alternatively, use a write_restart or write_data to restart from.

Also, there are ways to make sure the simulation keeps running even after your connection drops (e.g., tmux or GNU screen or a simple nohup and a &).