Bondchk failed with gcmc

Dear Axel,

Thanks for your rapid reply. As you suggested, I recompiled the latest LAMMPS development version--14May16.
Then I used it to run the same MD simulation, but I got the error "p0: not enough space for bonds! total=1652504570
allocated=2500", then I changed some different parameters of fix-gcmc command, but it didn't work. How can I
solve this problem?

Enclosed are some files to run the simulation. My input script is:

units real
dimension 3
boundary p p p
atom_style charge
read_data data.pd43cluster

mass 1 1.0000
mass 2 106.400

region pd sphere 50.0 50.0 50.0 20.0 side in
group pd region pd
neighbor 2 bin
neigh_modify every 1 delay 0 check yes
timestep 0.1

pair_style reax/c lmp_control safezone 1.6 mincap 100
pair_coeff * * ffield.reax.PdH H Pd
fix 4 all qeq/reax 1 0.0 10.0 1e-6 reax/c

min_style cg
minimize 1.0e-6 1.0e-6 100000 100000

fix 1 all nve
fix 2 all temp/berendsen 300.0 300.0 100
fix 1 all nve
fix 2 all temp/berendsen 300.0 300.0 100
#fix 2 all temp/rescale 100 1250.0 1250.0 1.0 1.0

run 5000
unfix 1
unfix 2

reset_timestep 0
compute_modify thermo_temp dynamic yes
fix 3 all nvt temp 300.0 300.0 100
fix 5 pd gcmc 20 2 2 1 370687 300.0 -2.5 0.01 region pd
thermo_style custom step atoms temp epair etotal press f_5[1] f_5[2] f_5[3] f_5[4] f_5[5] f_5[6]
thermo 100

dump 1 all cfg 1000 dump.*.cfg mass type xs ys zs
run 50000

Does it logically make sense in my script? Thank you for your help!

Best Regards,
Sen Zhang

Dear Lammps-users:

      Recently I'm trying to use fix-gcmc command to simulate the
absorption of H2 on Pd cluster with

the Reaxff potential. But after only a few hundred steps I encountered
the
error: "bondchk failed", then

according to the lammps users mailing list I tried a few methods to
avoid the error, but finally I came

to the same error no matter which method I tried.

The methods I have tried are as follows:

1. Change the value of neighbor command;

2. Add the mincap and safezone keyword and change their values in the
pair_style reax/c command;

3. Change the parameters of fix-gcmc command, such as N, X, M, random
seed and chemical potential;

4. Add fix-NVT command to combine GCMC with MD or not;

5. Change the size of the initial system.

The lammps version I used is 10Aug 2015, and my operating system is
Redhat CentOS 6.5. Enclosed

there is one important method missing in this list: try with the latest development version (14 May 2016 at the time of this writing).
there have been significant improvements to bother reax/c and fix gcmc since last summer.

are the input script and the data file. I have checked the input
script for weeks, but I still can't figure out

please note that these are useless without the matching reax force field file.

axel.

data.pd43cluster (2.45 KB)

ffield.reax.PdH (6.17 KB)

lmp_control (1020 Bytes)

Dear Axel,

Thanks for your rapid reply. As you suggested, I recompiled the latest LAMMPS development version--14May16.
Then I used it to run the same MD simulation, but I got the error "p0: not enough space for bonds! total=1652504570
allocated=2500", then I changed some different parameters of fix-gcmc command, but it didn't work. How can I
solve this problem?

the "not enough space for bonds" comes from a ridiculously large value
of "safezone". something between 1.5 and 2.0 should do.
the bondchk failed errors come when the system has changed too much
since the run was initialized. the way to address this is twofold:
- change the fix gcmc settings to throttle the speed at which atoms
are inserted, i.e. run it less frequently (say every 500 steps), and
with a reasonable number of insertion attempts (say about 20). this
will put less pressure on reaxff and the system to relax and adapt to
the changes. correspondingly 2 attempts every 50 steps would do the
same.
- break the run down in chunks. at the beginning of each chunk the
"buffer spaces" for system changes are freshly initialized. so instead
of run 50000 use:

run 10000
run 10000
run 10000
run 10000
run 10000

axel.