bug? Try Make PSS(like), with moltemplate use gaff.lt

Hi.

I tried make PSS(like) , ith moltemplate use gaff.lt.

But it can not well…

what is the probrem?

display error message.

Dear Murai

The problem you are running into is the same one you ran into previously. You are indeed using the wrong atom type(s) somewhere in your molecule(s). Unfortunately, moltemplate is misidentifying which atom is causing the problem.

The latest version of moltemplate fixes that problem.
Today (spurred by your email), I finally posted the updated version at www.moltemplate.org. Please download it, and let me know if you run into any new problems.

Anyway, when I run this version of moltemplate on your example, I get a different error message:

Error: No bond types defined for the bond between
atoms /atom:SS1[0]/C4 (type @/atom:GAFF/ca) and /atom:SS1[0]/S1 (type @/atom:GAFF/s2)

This means at least one of these two atom types is incorrect (ca, or s2).

If “s2” is correct, then the carbon atom should be c1 or c2.
The relevant lines from the “Bonds By Type” section of the “gaff.lt” file are included below:
@bond:c1-s2 @atom:c1 @atom:s2
@bond:c2-s2 @atom:c2 @atom:s2

However, if “ca” is correct, then the sulfur atom should be one of these: s, s4, s6, sh, ss, sx, sy. Here are the relevant lines from “gaff.lt”:
@bond:ca-s @atom:ca @atom:s
@bond:ca-s4 @atom:ca @atom:s4
@bond:ca-s6 @atom:ca @atom:s6
@bond:ca-sh @atom:ca @atom:sh
@bond:ca-ss @atom:ca @atom:ss
@bond:ca-sx @atom:ca @atom:sx
@bond:ca-sy @atom:ca @atom:sy

The description of these atoms is located in the “Data Masses” section of “gaff.lt
@atom:c1 12.01 # Sp C
@atom:c2 12.01 # Sp2 C
@atom:ca 12.01 # Sp2 C in pure aromatic systems
@atom:s 32.06 # S with one connected atom
@atom:s2 32.06 # S with two connected atom, involved at least one double bond
@atom:s4 32.06 # S with three connected atoms
@atom:s6 32.06 # S with four connected atoms
@atom:sh 32.06 # Sp3 S connected with hydrogen
@atom:ss 32.06 # Sp3 S in thio-ester and thio-ether
@atom:sx 32.06 # Special s4 in conjugated systems
@atom:sy 32.06 # Special s6 in conjugated systems

Thank you you for your persistence, both in trying to get moltemplate to work, and also in reporting your difficulties. I promised to update moltemplate to fix the bug moltemplate bug you reported last week, but I did not get around to it quickly enough. and you are still running into these kinds of problems. I apologize for this. Please download the new version of moltemplate and install it before proceeding.

Cheers

Andrew

(P.S. Let me know if you want me to spell your full name differently.)

Andrew’s fix will be in the next patch release (today or tomorrow).

Steve