buiding errors lammps mkl

Dear all,

I have tried many different options in my makefile but I am still getting the following error message while building the lammps mkl:

-lpthread -lmpi /opt/intel/mkl/lib/intel64/libfftw2xf_intel.a -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lstdc++ -o …/lmp_mkl
ld: cannot find -limf
make[1]: *** […/lmp_mkl] Error 1
make[1]: Leaving directory `/root/lammps-12Apr12/src/Obj_mkl’
make: *** [mkl] Error 2
[[email protected]…36…3390…:~/lammps-12Apr12/src]# vi ./MAKE/Makefile.mkl

and my make file is :

SHELL = /bin/sh

---------------------------------------------------------------------

compiler/linker settings

specify flags and libraries needed for your compiler

CC = icc
CCFLAGS = -O2 -fno-alias -ip -unroll0
DEPFLAGS = -M
LINK = icc
LINKFLAGS = -O -L/opt/intel/mkl/lib/intel64
#LIB = -lstdc++ -lpthread
LIB = -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lstdc++
ARCHIVE = ar
ARFLAGS = -rc
SIZE = size

---------------------------------------------------------------------

LAMMPS-specific settings

specify settings for LAMMPS features you will use

if you change any -D setting, do full re-compile after “make clean”

LAMMPS ifdef settings, OPTIONAL

see possible settings in doc/Section_start.html#2_2 (step 4)

LMP_INC = -DLAMMPS_GZIP

MPI library, REQUIRED

see discussion in doc/Section_start.html#2_2 (step 5)

can point to dummy MPI library in src/STUBS as in Makefile.serial

INC = path for mpi.h, MPI compiler settings

PATH = path for MPI library

LIB = name of MPI library

MPI_INC = -l/opt/intel/impi/4.0.3/intel64/include -DMPICH_IGNORE_CXX_SEEK
MPI_PATH = -L/opt/intel/impi/4.0.3/intel64/lib
MPI_LIB = -lpthread -lmpi

#MPI_INC = -DMPICH_IGNORE_CXX_SEEK
#MPI_PATH =
#MPI_LIB = -mt_mpi

FFT library, OPTIONAL

see discussion in doc/Section_start.html#2_2 (step 6)

can be left blank to use provided KISS FFT library

INC = -DFFT setting, e.g. -DFFT_FFTW, FFT compiler settings

PATH = path for FFT library

LIB = name of FFT library

FFT_INC = -DFFT_FFTW -I/opt/intel/mkl/include/fftw
FFT_PATH =
FFT_LIB = /opt/intel/mkl/lib/intel64/libfftw2xf_intel.a

Maybe I am missing something in the makefile, could you please tell me if you see something wrong in this configuration?

Thanks a lot & B.Regards,
Dogan

Dear all,

I have tried many different options in my makefile but I am still getting the following error message while building the lammps mkl:

-lpthread -lmpi /opt/intel/mkl/lib/intel64/libfftw2xf_intel.a -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lstdc++ -o …/lmp_mkl
ld: cannot find -limf

are you using any packages that use one of the libraries?
if yes, please check the Makefile.lammps files in the corresponding
subdirectory under lib. also, your setup for the intel compiler may
not be correct.

apart from that, i’d like to comment that the FFT in the intel mkl
is supported directly, no need to compile and use the fftw2
wrappers, as that would just add yet another wrapper layer.

make[1]: *** […/lmp_mkl] Error 1
make[1]: Leaving directory `/root/lammps-12Apr12/src/Obj_mkl’
make: *** [mkl] Error 2
[[email protected]…3390…:~/lammps-12Apr12/src]# vi ./MAKE/Makefile.mkl

arrrrrgggghhhhh!
another person that doesn’t know how much damage
you can do when you’re compiling software as root.

axel.