Compiling assistance

Could anyone please help me with the compiling error below? Thanks!

Creating… KIM_Config file… src/Makefile.KIM_Config.
Creating… KIM_Config file… src/utils/Makefile.KIM_Config.
Creating… KIM_Config file… src/model_drivers/Makefile.KIM_Config.
Creating… KIM_Config file… src/models/Makefile.KIM_Config.
Creating… KIM_Config file… examples/Makefile.KIM_Config.
Creating… KIM_Config file… examples/models/Makefile.KIM_Config.
Creating… KIM_Config file… examples/model_drivers/Makefile.KIM_Config.
Creating… KIM_Config_Helper file…
Creating… KIM_Config_Helper file…

** Building…
kim-api-objects **

Creating… KIM_API_Version.h.
Creating… KIM_API.o.
Creating… KIM_API_C.o.
Creating… intermediate file… kim_str.c.
sed: -e expression #2, char 20: unterminated `s’ command
make[1]: *** [kim_str.c] Error 1
make: *** [kim-api-objects] Error 2

Hi Shawn,

Can you provide some additional information? What version of the kim-api package are you using? What is the content of your Makefile.KIM_Config file?



Hi Ryan-

I’m using kim-api-v1.7.1. Below is the content. Thanks for your help! - Shawn

KIM_DIR = /usr/people/scoleman/OpenKim/kim-api-v1.7.1

KIM_LINK = dynamic-load

load default compiler options

include $(KIM_DIR)/build_system/Makefile.LoadDefaults

override default verbosity value (uncomment the line below if desired)


override default compiler options and other variables here

override default install options

#package_name =
prefix = /usr/people/scoleman/OpenKim
#includedir =
#exec_prefix =
#libdir =
#bindir =

load rest of generic make settings

include $(KIM_DIR)/build_system/Makefile.Generic

Hi Seawn,

Ah, yes. You've hit a known bug (at least known within the development group).

This will be fixed in the next bug-fix release (coming soon), but it is an easy patch. You should change line 240 of "kim-api-v1.7.1/build_system/Makefile.Generic" from

sed -e 's/^\([[:digit:]]\)/__\1/' -e 's/[^[[:alnum:]]]/_/g'` && \


sed -e 's/^\([[:digit:]]\)/__\1/' -e 's/[^[:alnum:]]/_/g'` && \

Note, the change is in the 2nd half of the line, where a set of '[' ']' brackets have been removed around the :alnum: string.



Thanks! That worked. Just want to double check that the following behavior for “make add-OpenKIM” option is known.


excalibur:> make add-OpenKIM
printf “Complete download of OpenKIM Repository Model Drivers and Models not yet available.\n” && false
Complete download of OpenKIM Repository Model Drivers and Models not yet available.
make: *** [add-OpenKIM] Error 1

Hi Shawn,

Thanks for the reminder (and implicit request)! We're working on multiple new ways of making available the content of to users. We should have some announcements this summer.

However, I've put this particular one on my more immediate list and will aim to implement this functionality for the next bug-fix release.

Keep in touch, it is great to know people are using the system and to hear about their interests and needs.