Compiling LAMMPS in parallel

Dear lammps users,
I am trying to compile LAMMPS in parallel. I am using Ubuntu 14.04. I tried to give the command make mpi in the src directory of LAMMPS, but it showed the following error message:

make[1]: Entering directory /home/atreya/lammps/src/Obj_ubuntu_simple' ../../lib/quip/Makefile.lammps:8: *** Environment variable QUIP_ROOT must be set.. Stop. make[1]: Leaving directory /home/atreya/lammps/src/Obj_ubuntu_simple’
make[1]: Entering directory /home/atreya/lammps/src/Obj_ubuntu_simple' ../../lib/quip/Makefile.lammps:8: *** Environment variable QUIP_ROOT must be set.. Stop. make[1]: Leaving directory /home/atreya/lammps/src/Obj_ubuntu_simple’
make: *** [ubuntu_simple] Error 2

How do I set this Environment variable QUIP_ROOT and what should I set it to?

Thanking you in advance,

Atreya.

Dear lammps users,
I am trying to compile LAMMPS in parallel. I am using Ubuntu 14.04. I
tried to give the command make mpi in the src directory of LAMMPS, but it
showed the following error message:

make[1]: Entering directory `/home/atreya/lammps/src/Obj_ubuntu_simple'
../../lib/quip/Makefile.lammps:8: *** Environment variable QUIP_ROOT must
be set.. Stop.
make[1]: Leaving directory `/home/atreya/lammps/src/Obj_ubuntu_simple'
make[1]: Entering directory `/home/atreya/lammps/src/Obj_ubuntu_simple'
../../lib/quip/Makefile.lammps:8: *** Environment variable QUIP_ROOT must
be set.. Stop.
make[1]: Leaving directory `/home/atreya/lammps/src/Obj_ubuntu_simple'
make: *** [ubuntu_simple] Error 2

How do I set this Environment variable QUIP_ROOT and what should I set it
to?

​do you want to use the QUIP package? then you need to read the
installation instructions for that specific package. this is a package that
depends on an external library (like several other LAMMPS packages).

otherwise, just uninstall the package (and refer to the general
compilation/installation instructions).

axel​