Creating carbon thin film in a simulation box

Please post to the list not to me, thanks.

The z dimension is 14.56 angstroms long, and yet the wall/reflect is
place at -0.5 ~ 10.0 angstroms. With a fixed z boundary, why wouldn't
you lose atoms that originally lie between 10.0 ~ 14.56 ?

Ray

Dear Ray

I tried changing the wall/reflect to -1.0~15, but lost atoms still occured.

Is there any chance of creating just 1000 atoms within the thin film in a big box, so that the whole system would not involve too many atoms to result in atoms lost problem?

Thanks! :slight_smile:

atom_style charge
boundary p p f
units real
dimension 3
neighbor 2.5 bin
neigh_modify delay 1 every 1 check yes

Please read fix wall/reflect doc page on whether this fix is invoked
during energy minimization or not. Also, using fix nve with minimize
does not make a lot of sense.

Ray

And also pay attention to whether you use
box or lattice units when defining the position
of the wall. You may not be putting the wall
where you think you are.

Steve

Dear all

The minimization worked after i changed my boundary to “p p s”. However, the following error messages occurred.

It was stated that address not mapped. But previously when I ran reax/c simulation, no error messages occured until i tried to do a non-periodic case like this one.

Is there any advice?

Thank you and sorry for the trouble again.

[compute275:09731] *** Process received signal ***
[compute275:09731] Signal: Segmentation fault (11)
[compute275:09731] Signal code: Address not mapped (1)
[compute275:09731] Failing at address: 0x2b1aafb30ef8

[compute275:09731] [ 0] /lib64/libpthread.so.0 [0x315a00e4c0]
[compute275:09731] [ 1] /usr/local/lammps/bin/lammps-11Jan13(_Z14Compute_ForcesP11reax_systemP14control_paramsP15simulation_dataP7storagePP9reax_listP15output_controlsP13mpi_datatypes+0x2f7) [0xc95457]
[compute275:09731] [ 2] /usr/local/lammps/bin/lammps-11Jan13(_ZN9LAMMPS_NS9PairReaxC7computeEii+0xd41) [0xb870b1]
[compute275:09731] [ 3] /usr/local/lammps/bin/lammps-11Jan13(_ZN9LAMMPS_NS6Verlet3runEi+0x6e4) [0xd01404]
[compute275:09731] [ 4] /usr/local/lammps/bin/lammps-11Jan13(_ZN9LAMMPS_NS3Run7commandEiPPc+0xce3) [0xcc6e53]
[compute275:09731] [ 5] /usr/local/lammps/bin/lammps-11Jan13(_ZN9LAMMPS_NS5Input15execute_commandEv+0x2847) [0x8525d7]
[compute275:09731] [ 6] /usr/local/lammps/bin/lammps-11Jan13(_ZN9LAMMPS_NS5Input4fileEv+0x281) [0x84e551]
[compute275:09731] [ 7] /usr/local/lammps/bin/lammps-11Jan13(main+0x94) [0x867084]
[compute275:09731] [ 8] /lib64/libc.so.6(__libc_start_main+0xf4) [0x315981d974]
[compute275:09731] [ 9] /usr/local/lammps/bin/lammps-11Jan13 [0x543459]
[compute275:09731] *** End of error message ***

I can't reproduce this error and the minimization ran to completion.

Please post the complete input script with a smallest size possible
that actually reproduces the error. It is possible you ran out of
physical memory.

Ray

Dear Ray

The following is the input script. The minimization went well. But before it could start the simulation of heating up my system, the whole simulation was stopped with the error as shown in previous email. I tried it a few times already, i cleared my physical memory but it still didn’t work out.

Thanks so much! :slight_smile:

atom_style charge
boundary p p s
units real
dimension 3
neighbor 2.5 bin
neigh_modify delay 1 every 1 check yes

Advices from myself and Steve were given but not followed.

Not using these fixes with minimization was the first advice, checking
where you are placing the reflecting wall is second. The second run
has wall mistakenly placed again.

Additionally, trying to avoid errors by attempting to Ignore lost
atoms does not fix the problem. Please fix these mistakes.

Ray