Difference in output

I am using the same restart file but getting different output (except for Temperature and volume) each run. Below are my input file and the output (for two cases). What could possibly be wrong?

Input:

#polymer

units real
atom_style full

boundary p p p

pair_style hybrid lj/charmm/coul/long/opt 10.0 12.0 lj/charmm/coul/charmm 10.0 12.0 0.1 1.0
bond_style harmonic
angle_style cosine/squared
dihedral_style charmm
#improper_style harmonic
special_bonds lj/coul 0.0 0.0 1.0
kspace_style pppm 1.0E-6

read_restart ./nextrestart

#reset_timestep 0

restart 100000 ./restart.surlyn

#delr
neighbor 2.0 bin

thermo 100
thermo_style custom step cpu pe etotal temp press vol enthalpy

dump 1 all custom 5000 ./HISTORY.lam id mol type xu yu zu
dump 2 all custom 200000 ./CON.end id mol type q xu yu zu

fix 1 all npt temp 298.0 298.0 100.0 iso 1.0 1.0 1000.0

timestep 1.0

run 100

The output file:

LAMMPS (26 May 2013)
Reading restart file …
orthogonal box = (-33.0914 -33.0914 -33.0914) to (33.0914 33.0914 33.0914)
2 by 3 by 4 MPI processor grid
11350 atoms
11203 bonds
12215 angles
12886 dihedrals
Finding 1-2 1-3 1-4 neighbors …
4 = max # of 1-2 neighbors
6 = max # of 1-3 neighbors
10 = max # of special neighbors
Resetting global state of Fix 1 Style npt from restart file info
PPPM initialization …
G vector (1/distance)= 0.250199
grid = 45 45 45
stencil order = 5
estimated absolute RMS force accuracy = 0.000273859
estimated relative force accuracy = 8.24719e-07
using double precision FFTs
3d grid and FFT values/proc = 11484 4140
Setting up run …
WARNING: Inconsistent image flags (…/domain.cpp:599)
Memory usage per processor = 11.6548 Mbytes
Step CPU PotEng TotEng Temp Press Volume Enthalpy
5000000 0 -35272.489 -25243.301 296.46528 33.517306 289892.06 -25101.598
5000100 1.6245811 -35180.851 -25082.957 298.49626 3.1533231 289852.93 -25069.627
Loop time of 1.62464 on 24 procs for 100 steps with 11350 atoms

NEW CASE
5000000 0 -34307.389 -24278.202 296.46528 33.433935 289892.06 -24136.85

I am using the same restart file but getting different output (except for
Temperature and volume) each run. Below are my input file and the output
(for two cases). What could possibly be wrong?

hard to say, what else is different between the two runs?

axel.