dump compiling issue

I tried compiling a new dump that worked just fine until I attempted it with the newest 2019 version of the code using the intel 2019 and the 2018 compiler. In that case I get an error
regarding the enumeration on line 97 of dump.h where the compiler expects a valid identifier:


I guess theres some kind of portability issue happening here; seems that enumeration didn’t exist in the 2018 version of the code I was accustomed to running this dump on.

Seems changing the enumeration elements to have a V (for variable) in front allowed it to compile along with changes to their uses in dump_custom and dump_cfg . I guess capitalizations of reserved keywords might be problematic.



a) to the best of my knowledge, this is valid c++ code. so i don’t see why it should fail compiling unless it is due to some preprocessor define that is explicitly or implicitly set.
b) the enum did exist before. it was just moved to the header to have the same definition consistently shared across multiple .cpp files rather than having to manually keep them in sync.