Error: Bond/angle/dihedral extent > half of periodic box length

I am currently receiving this error while attempting to cross-link a polymer system. I utilize a static method in which I run a program to cross-link atoms within a specified cut-off distance. This distance is only 4 Angstroms, and my box size is much larger than this. I have written the program to recognize periodic boundaries and cross-link atoms accross them if they are within the cut-off. From what I can gather about this error (I am still very unclear how it works and what it prevents), I think that I am creating bonds/angles/dihedrals across periodic boundaries and lammps is not able to recognize this. I run the crosslink program on dump files generated from previous simulations. I do not change the coordinates of any atoms after the crosslinking process. Is LAMMPS able to identify whether or not a bond should be created across a periodic boundary? Any help with this error, or suggestions on how to get around it would be greatly appreciated. I was thinking I might run a minimization with only new bond data after crosslinking and then add the angles and dihedrals after the system is minimized using only bond data…Thoughts?

Thanks a million,
Cameron Hadden

The error check is a pretty simple one. Usually people who have
this problem think there is no such bond in their system, but there
actually is. Can you post a data file that gives this error on
start-up? Along with an input script that reads it?


I don't know if it helps, but I recently got this particular error
when I used an external program to generate a list of atom
coordinates, and it supplied them in the wrong order. Specifically, I
had built a data file which messed up the atom-ID numbers.

If you are using your own program to build a LAMMPS data file, then be
sure to visualize the actual data file which LAMMPS is reading (with
topotools for example), and check that the bonds look reasonable. (I
attached some generic instructions for how to do this to this email.
Hopefully all of your atomic coordinates are contained in the actual
data file, not in "set" commands.)

This could have nothing to do with your situation.
good luck!

README_visualize.txt (2.85 KB)