error in compiling KIM in lammps: ../lmptype.h:86:19: error: ‘INT64_MAX’ was not declared in this scope

KIM in Lammps($LMPHOME/lib/kim) was compiled in a server.
First KIM was well installed with cmake(3.12) and then
lammps can include KIM package,

then during compilation with make in lammps, it shows error message as follows:

CentOS 7.4, intel/18.0.3 impi/18.0.3 cmake/3.12.3

Hello,

Thanks for your message and for using the KIM system!

The error you list does not appear to be related to KIM at all.

Maybe try to build lammps without KIM first to see if you can get that to succeed. (Check the lammps webpages and mailing list for help.) Then, once that works OK try again with the KIM package enabled.

Cheers,

Ryan

https://z.umn.edu/relliott