Error: Invalid pair style with Reax and Reax/C

Hi !!!

I have already successfully compile Lammps including reax and reax/c without errors.
What I did was the following:

  1. Download the last version of lammps and the patch from August 12/ 2012
  2. Unzip and untar lammps.
  3. Install the patch.
  4. go to into lammps/lib/reax
  5. compile the library: make -f makefile.gfortran
  6. copy the content of Makefile.lammps.gfortran in Makefile.lammps
  7. go to lammps/src
  8. make yes-reax
  9. make yes-user-reaxc
  10. compile lammps make openmpi

Unfortunately, when I try to run the examples (AB, .rdx and .tatb ), I obtain an error:

Error: Invalid pair style

Can You help me?


John Michael Espinosa Duran
PhD Student
Indiana university

PD: Also, I tried only with reax, and then only with reaxc, and it does not works.

Hi Jhon Michael,

It seems your executable was not successfully compiled. Type
"lmp_openmpi -h" and see if you have reax and reax/c listed within
pair styles. Also, if you downloaded the latest version you wouldn't
need to install the patch.


Dear Ray

  1. Thanks for your answer.
  2. I tried lmp_openmpi -h, but it says “ERROR: invalid argument”
  3. I installed the patch of August 12-2012.
  4. I run the peptide example and other files that I preprared that do not require
    the reactive force field and they work perfect.
    So, what can I do
    John Michael

Ho John Michael,

It seems you still don't have reax or reax/c installed. If you do
"lmp_openmpi -h", you have to have lmp_openmpi in your bin path,
otherwise go to /src and do "./lmp_openmpi -h".

See this webpage for how to make lammps with optional packages:


Dear Ray

Ok, I did ./lmp_openmpi-h, and for pair styles, it includes reax/c and reax, I attached what I obtained for pair styles.
To include the packages, I did the information included in the link that you send me but instead of “make g++”, I did “make openmpi”

Then I do not why I obtain invalid par style when I try to run the examples.

Thanks for your collaboration.
John Michael

Pair styles: adp airebo beck bop born/coul/long born/coul/wolf born buck/coul/cut buck/coul/long buck comb coul/cut coul/debye coul/long coul/wolf dpd dpd/tstat eam/alloy eam/fs eam eim gauss hbond/dreiding/lj hbond/dreiding/morse hybrid hybrid/overlay lcbop lj96/cut lj/charmm/coul/charmm lj/charmm/coul/charmm/implicit lj/charmm/coul/long lj/cubic lj/cut/coul/cut lj/cut/coul/debye lj/cut/coul/long lj/cut/coul/long/tip4p lj/cut lj/expand lj/gromacs/coul/gromacs lj/gromacs lj/smooth lj/smooth/linear morse reax/c reax rebo soft sw table tersoff tersoff/zbl yukawa

The examples are very standard, and if you do have reax or reax/c
successfully installed you should be able to run them without a
problem. Please check if you have the executable, which is compiled
with reax or reax/c, located, copied or symbolic linked to the
example/reax dir where you are trying to run. That could be the only
reason I can think of.