ERROR on proc 2: Bond atom missing in image check (../domain.cpp:765)

Hi Everyone,
I’m doing a simulation regarding a gold cluster on a graphite substrate and here is my input file:

******Initialization

units metal
boundary p p p
atom_style full
neigh_modify delay 0 every 1 check yes
pair_style hybrid/overlay eam/fs lj/charmmfsw/coul/long 10.0 12.0
pair_modify mix arithmetic
kspace_style pppm 1e-6

atom_style full
bond_style harmonic
angle_style charmm
dihedral_style charmmfsw
special_bonds charmm
improper_style harmonic

***read_data

read_data substrate_input.data

****Define pair styles

pair_coeff * * eam/fs Au-Grochola-JCP05.eam.alloy NULL Au
pair_coeff 1 2 lj/charmmfsw/coul/long 0.033244 2.9580 0.033244 2.9580 #lj/charmmfsw/coul/long epsilon_graphite sigma_graphite epsilon_gold sigma_gold cutoff
pair_coeff 1 1 lj/charmmfsw/coul/long 0.07000000000000 3.55005321204562 0.07000000000000 3.55005321204562 # CG2R61
kspace_style pppm 1.0e-4
kspace_modify gewald 0.2428

**Other parameters

velocity all create 300.0 12345
timestep 0.001
minimize 0.0 1.0e-7 1000000 100000

group substrate type 1
group Au type 2

fix 1 substrate freeze

thermo 5000
thermo_style custom step temp etotal pe ke vol press lx ly lz
thermo_modify flush yes

fix 2 Au momentum 1 linear 1 1 1 angular

restart 5000 restart.1 restart.2

dump 1 all custom 5000 Au_on_substrate_eq.lammpstrj id type x y z
dump_modify 1 sort id

fix 3 all nvt temp 300.0 300.0 0.1

Run the job***

run 5000000 #5 ns

write_data Au_on_substrate_eq.data

But when I run it, there is an error like this:ERROR on proc 2: Bond atom missing in image check (…/domain.cpp:765).

I’m very confused about this and may I ask for someone’s help?
Thanks
Kevin

Hi Dr. Axel Kohlmeyer, I saw that you edited the post but I cannot find any difference. May I ask where I should change my input file?

I did not edit it, but change the category.

Please note that your input file is hard to read because you just copied the text. This creates problems because the forum software recognizes several special characters as formatting directives (similar to markdown). You thus should bracket your copied quoted text with triple backquotes (```) so it will remain unchanged (plus some syntax highlighting may be added).

This typically means there is a fundamental error in how your data file was generated or the geometry of your molecules in them is inconsistent with the bond topology or something similar.

You can search for the error message in the forum archive or on google and you’ll see what kind of reasons there were when others had encountered that same error message.

Hi, not pretty sure, but in my simulation, when I got the error related to bond atom missing. normally i can fix this by decrease the timestep.