error "overlapping large/large in pair_colloid"

Hello users,

I met an error said “overlapping large/large in pair_colloid”. I read previous mailing list about this error, and Steve commented either a bad initial config or a bad dynamics is happening.
I am not sure what you mean about a bad initial config or how to correct this, but I have checked my large particles are all 30 A away from each other. I’ve tried a very small cutoff distance. Same error immediately occurs if I set the step size 0.1 fs. Then I also tried smaller size, 0.001 fs, the simulation can run for a while, but then same error happens.
The following is my input script. I am trying to use two spheres (type 1 and 2) to make a hexagonal large particle. Thank you in advance.

----------------- Init Section -----------------

units real
atom_style hybrid full sphere
bond_style fene
pair_style hybrid/overlay colloid 10 yukawa/colloid 0.01 10
special_bonds fene
boundary p p p

----------------- Atom Definition Section -----------------

read_data “”

----------------- Settings Section -----------------

group particle molecule <> 1 36
group water type 3
neigh_modify exclude molecule particle
neigh_modify exclude molecule water

pair_coeff 1 1 colloid 9.36 1.0 16 16
pair_coeff 2 2 colloid 21.89 1.0 16 16
pair_coeff 1 3 colloid 7.06 0.55 16 0.1 1.0
pair_coeff 3 3 colloid 5.328 0.1 0.1 0.1 1.0
pair_coeff 1 2 colloid 14.31 1.0 16 16
pair_coeff 2 3 colloid 10.80 0.55 16 0.1 1.0
pair_coeff 1 1 yukawa/colloid 0.41
pair_coeff 2 2 yukawa/colloid 0.046
pair_coeff 1 2 yukawa/colloid -0.137
bond_coeff 1 1.0 1.5 1.0 1.0

bond_coeff 1 100 2.0

Load the atom coordinates:

include “”

neighbor 2.0 bin
communicate multi vel yes

set type 1 charge -0.002
set type 2 charge 0.0005

----------------- Run Section ---------

fix rigid particle rigid molecule

timestep 0.1
dump 1 all custom 1000 test.lammpstrj id mol type x y z ix iy iz

fix 1 all langevin 298 298 100 482795
fix 2 all nve
thermo 500
thermo_style custom step temp vol press etotal
run 5000000

run 5000000

run 5000000

write_restart test.rst

With so many interactions, I think it’d be hard to pin point whats actually going wrong(unless someone is used to these problems I guess). Try implementing the interactions piece by piece into your script, (probably starting with the colloidal interactions since thats what’s giving the error). The errors will likely show up before you bring everything together.

Also why use small cutoffs?(in comparison to the relavant length-scale of interaction) That will probably only exacerbate problems related to bad dynamics…

Hi Eric,

Thank you for your reply. I ran yukawa/colloid only before, no error occurs.
I thought a smaller cutoff may decrease the chance of “overlapping”, I may be wrong.


In these instances, smaller cut-off just refers to where the force cut-off is. That is to say the cut-off sets the maximum separation where you calculate forces between particles. If your cutoff is especially small particles won’t ‘feel’ one another until its too late.

There are also additional problems you might discover later on when trying to compare with others, and will arise because your potentials will appear essentially discontinuous.