error: /usr/bin/ld: cannot find -lmeam

Hi all,

If I compile LAMMPS without install additional packages, the lmp_openmpi executive works fine. But when I activate “meam” package, the error shows like this:

/usr/bin/ld: cannot find -lmeam
collect2: ld returned 1 exit status
make[1]: *** […/lmp_openmpi] Error 1

Does anyone know how can I fix this error? Where can I find this -lmeam file? Thanks

Regards,
Larry

Hi all,

If I compile LAMMPS without install additional packages, the lmp_openmpi
executive works fine. But when I activate "meam" package, the error shows
like this:

/usr/bin/ld: cannot find -lmeam
collect2: ld returned 1 exit status
make[1]: *** [../lmp_openmpi] Error 1

Does anyone know how can I fix this error? Where can I find this -lmeam

yes. read the documentation!

the meam package requires the compilation of
an additional library that is shipped with lammps.
once you've done that, it will work.

axel.