Error with running multiple processors with pppm but not ewald

Though I have a very interesting problem when I try
to run pppm with more than 4 processors. You can see below (I got same error
before using FFTW3 as well)

It sounds like other people will need to test this with your LAMMPS
data file and input scripts.

I could be wrong, but I suspect the error you have does not depend
much on the details of the system you are simulating. I am assuming
the full-size data file is too big to post, even if you felt
comfortable posting it. So you will probably have to make the system

  If it helps, I attached a small system consisting of 64 water
molecules "" "" (ignore the corresponding .LT files)
Can you try running this simulation using mpirun -np 6?
Do you still get the error with "MPI_Waitany"?


Using google, I found this thread (in addition to your post)

It does indeed compile.

Thanks for checking this. Although it probably is not relevant, to be
thorough, I'm attaching this makefile too (which we discussed earlier
which you used to build LAMMPS). (9.58 KB) (1.1 KB) (1.44 KB) (420 Bytes)

Makefile.ubuntu_parallel (1 KB)