"fftw" related

Dear users,

Currently I am using Lammps on my local linux box, but as I planed to install Lammps on some national computational facility for faster computation. I have checked for the prerequisite of lammps like mpi, c- compiler, fortran-compiler and as well as fftw in the grid. Unfortunately I found that fftw 3.x is present there and this package is used by other package like matlab, hyperworks etc. As fftw 2.x is compatible for lammps, I request them to roll back fftw to the older version but not solved.

In this circumstance can it be possible to use two versions (2.x and 3.x) of fftw simultaneously ? Is there any way to install lammps in another way ?

Thanks

Dinesh

Hi, Dinesh:

LAMMPS now supports a large number of FFT solvers, including FFTW3, so there's no need to roll back to FFTW2.

Take a look at the installation instructions for more information.

--AEI

Dear users,

Currently I am using Lammps on my local linux box, but as I planed to
install Lammps on some national computational facility for faster
computation. I have checked for the prerequisite of lammps like mpi, c-
compiler, fortran-compiler and as well as fftw in the grid. Unfortunately I
found that fftw 3.x is present there and this package is used by other
package like matlab, hyperworks etc. As fftw 2.x is compatible for lammps,
I request them to roll back fftw to the older version but not solved.

this is nonsense. a) you can have multiple compilations of fftw
installed concurrently.
b) you don't even need to have those installed at the system level,
you can compile it
yourself c) most proper supercomputing centers offer a variety of fftw
versions as environment modules

In this circumstance can it be possible to use two versions (2.x and 3.x) of
fftw simultaneously ? Is there any way to install lammps in another way ?

RTFM. LAMMPS supports fftw-3 and several other FFTs for two years now.
you don't even need *any* fftw version installed. LAMMPS will use an
internal FFT library in that case.

please don't spread incorrect information.

thanks,
     axel.

Dear Axel and ismail,

Extremely sorry, I had wrong information. Thanks for your info so promptly.

Thanks again.

Dinesh

Dear Axel and ismail,

Extremely sorry, I had wrong information. Thanks for your info so promptly.

everything you need to know is described in detail on the lammps
homepage and the bundled documentation and easy to look up.

axel.