gcmc molecule bond generation problem

Dear Lammps users,

I am having a strange issue with a gcmc simulation and even after a deep search on similar problems experienced by others and several testing I couldn’t find a solution. Here is my problem:

I’m just trying a adsorb water molecules into a calcium silicate system using Lennard Jones potential without any long range interactions (its another issue if I use long range). The adsorption works fine if I use a host system with water molecules only. However, if I try to have a composite system with the silicate and the water molecules then I get a “segmentation fault” error.

I looked it up and according to previous mail list suggestions I did keep extra atom types in the host data file for the incoming water molecules. I also tried with an anhydrous calcium silicate host system (with no pre-existing water) and it gives me a different error “Molecule auto special bond generation overflow”. I have only Hw-Ow bond within the water molecules with no other special bonds. Here is my complete input script:

variable seed equal 381027

variable name string silicate-water
log log.${name}

units metal
atom_style full
bond_style harmonic
dihedral_style none
improper_style none
angle_style harmonic

pair_style lj/cut 12.00

read_data data.water #data.anhydrous or data.silicate_5-water doesn’t work

molecule watermol mol.water

group water type 5 6

mass 1 28.065 #Si
mass 2 16.00 #O
mass 3 40.078 #Ca1
mass 4 40.078 #Ca2
mass 5 16.00 #Ow
mass 6 1.00 #Hw

set type 1 charge 1.72
set type 2 charge -1.1608219
set type 3 charge 1.43
set type 4 charge 1.70
set type 5 charge -0.82
set type 6 charge 0.41

pair_coeff * * 0.000000 0.100000 0.0000000
pair_coeff 1 2 0.2433e-4 3.6716
pair_coeff 2 2 0.5392e-1 3.0687
pair_coeff 2 3 0.3773e-4 4.898
pair_coeff 2 4 0.6331e-4 4.898
pair_coeff 1 5 0.2299e-4 3.6298
pair_coeff 3 5 0.3802e-4 4.898
pair_coeff 4 5 0.2617e-4 5.0168
pair_coeff 5 5 6.74E-03 3.5532
pair_coeff 2 5 0.2278e-3 4.7557

bond_coeff 1 45.93 1.012
angle_coeff 1 3.29136 113.24

#pair_modify table 0
kspace_style none #pppm 1.0E-4
neighbor 1.0 bin
neigh_modify delay 4 every 2 check yes

timestep 0.001
dump id all atom 1000 dump.${name}
thermo 10
thermo_style custom step pe ke temp press density vol atoms

#fix m1 all rigid/nvt/small molecule temp 300 300 100 mol watermol
#fix_modify m1 dynamic/dof no

variable tfac equal 5.0/3.0

fix g1 all gcmc 10 100 100 0 27868 300 0.1 0.01 mol watermol tfac_insert ${tfac} group water

fix r3 all nvt temp 300.0 300.0 1.0
run 1000

Its surprising that with the same setting the gcmc simulation works just fine for only water (data.water) but not for the other two options when silicate species are present. I have kept the atoms types consistent for all three data files and they can be read in the input file without any need for additional changes in types. I can run nvt and all other stuff using the potential but its only the gcmc thats causing the problem. I am attaching the three data files (water, anhydrous and mixed system) and the molecule file for water if someone wants to reproduce the errors. I tried my best to find a solution myself but with no luck so far. So I need advice to find what I’m doing wrong. Any suggestion or guidance is very much appreciated. Thanks in advance for the help.

Best regards,

data.anhydrous (3.54 KB)

data.water (6.67 KB)

in.gcmc (2.62 KB)

mol.water (338 Bytes)

data.silicate_5-water (2.83 KB)

Forgot to mention I’m using 31 March 2017 version of lammps.