GCMC with full-energy

Hi Lammps community

I had received the update of the recent fix gcmc with happiness as i am using systems with both hybrid pairs and kspace.

Yet, when i get involved with the updated version (15Feb), i have seen that, probably full_energy option of fix gcmc made it much slower. Cosidering the update in warning sections, i assume lammps automatically turns full-energy on if there is kspace calculation am i right?

I am attaching my input (with 1 gcmc step), my data and molecule file with three output files, one with full-energy option on, one with full-energy option off (yet i think it is turned on automatically) and one ran on a previous version of lammps.

Is it normal that the newer version is this much slower?

co2.txt (487 Bytes)

321.data (1.73 MB)

inputgcmc1.in (817 Bytes)

output.fullenergy (5.36 KB)

output.nofullenergy (5.43 KB)

output.oldlammps (5.04 KB)