Getting errors while running script in Lammps (ubuntu)

Dear Lammps users,

My lammps was running fine till yesterday but today I am getting the following errors while running input script. Please extend any suggestion why I am getting this error. I didnt install anything new on my work station.

user@…6292…:~/RAJESH/Reaxff/P5/ZZ/H-BN/H-BN_crack_area_2$ mpirun -np 4 lmp_mpi -sf omp -pk omp 4 -in in.bn

Are you sure nothing changed? It seems lammps is unable to find your MPI library, so maybe it got (re)moved or it is no longer in your LD_LIBRARY_PATH?

Dear Stefan,

I am sure I did change nothing. I also installed openmpi again but still getting the same error.

Thanks.

Rajesh

Dear Stefan,

I am sure I did change nothing. I also installed openmpi again but still
getting the same error.

this is a long shot, but have you checked, whether you have an "LCP
infection" in your machine? :wink:

but seriously, it is the very nature of computers to do *exactly* the
same thing when asked to do *exactly* the same thing. so the logical
conclusion is: something *has* to be different. this can be some
environment variable (perhaps reset by some other software that you've
run?) or a permission problem (have you run anything recently using
"sudo"?) or a file system problem.

at any rate, is has to be a local issue and can in *no way* be a LAMMPS issue.

axel.

P.S: for people that haven't been around the block as many times as
me: LCP => https://en.wikipedia.org/wiki/Little_Computer_People

Thanks Axel. I compiled lammps again and its working.