Granular style and lattice problems

Hello,

I am trying to create a lattice of granular particles but i am running into some problems. No matter how i configure it it will not allow me to create over 1728 particles in my lattice (region set to 0 .12 0 .12 0 .12 for units box). In the attached file if i were to increase the size of my region to .13 from .12 i will have the following error: ERROR on proc 0: Neighbor list overflow, boost neigh_modify one or page . Attached are my two files, in.lattice_electro ( uses hybrid charge and granular atom_style to add a charge to the particles) and in.lattice_noElectro ( just uses granular atom_style). In in.lattice_electro it also produces this right after the first timestep of the run:

Step Atoms KinEng 1 Volume E_coul Enthalpy E_pair
1 1728 111.00119 3.1715893e-12 0.0017323236 0 8.8957801e+09 0
INFO: more than 15 touching neighbor atoms found, growing contact history.
INFO: more than 30 touching neighbor atoms found, growing contact history.

INFO: more than 1680 touching neighbor atoms found, growing contact history.
INFO: more than 1695 touching neighbor atoms found, growing contact history.
INFO: more than 1710 touching neighbor atoms found, growing contact history.
INFO: more than 1725 touching neighbor atoms found, growing contact history.

I am pretty much stuck and any advice would be appreciated.

Thanks for your time,

Ryan Houlihan

in.lattice_electro (2.85 KB)

in.lattice_noElectro (2.74 KB)

So you need to use the neigh_modify page command,

I set my page to something very large, just start at 10000 or so and bump it up by another factor of 10 if it still complains.

~Nickhil Rokkam

Thanks for the response. I have set

lattice sc .001
region reg block 0 .02 0 .02 0 .02 units box

and

neigh_modify page 100000 one 10000

The initialization works alright, albeit a little slow and i no longer receive my initial error:

Setting up run …
Memory usage per processor = 1206.42 Mbytes
Step Atoms KinEng 1 Volume E_coul Enthalpy E_pair
0 8000 0 0 8.120601e-06 5.39256 3.5890007e+10 5.39256
1 8000 0 0 8.120601e-06 5.39256 3.5890007e+10 5.39256
Loop time of 9.07241 on 1 procs for 1 steps with 8000 atoms

Then during my actual run i get
run 200 upto
Setting up run …
Memory usage per processor = 1206.42 Mbytes
Step Atoms KinEng 1 Volume E_coul Enthalpy E_pair
1 8000 0 0 8.120601e-06 5.39256 3.5890007e+10 5.39256

It then hangs for a minute or two and then gives me the the ERROR on proc 0: Too many neighbor bins. So i am still unable to create a lattice while multiple thousand granular particles.

Thanks,

Ryan Houlihan

ryan,

Thanks for the response. I have set

lattice sc .001
region reg block 0 .02 0 .02 0 .02 units box

and

neigh_modify page 100000 one 10000

The initialization works alright, albeit a little slow and i no longer
receive my initial error:

when you need to bump up the parameters for the
neighbor lists, that is usually an indication that something
with your interaction parameters is wrong, i.e. your
system is collapsing and you suddenly have more neighbors
that expected. for granular simulations, this would be
particularly true, since you are only interested in your
immediate neighbors and have no long-range interactions,
i.e. your cutoff radius should be rather short.

a good way to look at this is to write out coordinates (=dump)
in every step (or every 5 or 10) and visualize the result to see
what is happening that is physically unexpected.

cheers,
     axel.

More bluntly, how is it possible that you have 1700+ touching neighbors
in your model. This means one particle is touching thousands of
others. Not possible unless you are highly overlapped which is not
proper for a granular model.

Steve

Thanks for the responses:

By setting neigh_modify page to a large number i was able to create a lattice of 8000 particles with an average of 4000 neighbors per particle which i understand does not make any sense.
When i view the dump files in paraview it is displayed correctly with even spacing between all 8000 particles and over numerous timesteps the lattice does not collapse or blow up in anyway.
I have been searching around but i can not find a force cutoff for the gran pairstyles, the only reference i found to cutoff was in communicate but modifying that had no effect.
Any pushes in the right direction would be greatly appreciated. Also for the electrostatics model modifying the coul/cut cutoff had no effect in regards to reducing the amount of neighbours.

Thanks

Ryan

Even spacing does not tell you anything at all if paraview does not take the radius of the particles from the dump files as well.
Maybe its just a problem of length scale?

Step Atoms KinEng 1 Volume E_coul Enthalpy E_pair
0 8000 0 0 8.120601e-06 5.39256 3.5890007e+10 5.39256

If I interprete this line of your output correct your volume is just 8e-6?
So you have a system with the dimensions of approximately 0.02x0.02x0.02?

Cheers
Christian

-------- Original-Nachricht --------

Even spacing does not tell you anything at all if paraview does not take the radius of the particles from the dump files as well.
Maybe its just a problem of length scale?

or the units that were selected?

axel.

Assuming you are using atom_style sphere for granular
particles, then you have to define a diameter for every particle
(the default diam is 1.0). That diameter determines whether
there are overlaps, for the lattice spacing you are placing
the particles on. The "set" command can change the diameters
if you like.

Steve