Help for using dump molfile

Hello,

I’m trying to use dump molfile command, but it doens’t works.

the command I’m trying to use is

dump 1 all molfile 1000 test.pdb pdb

and the error message is

ERROR on proc 0: No suitable molfile plugin found (…/dump_molfile.cpp:105)

I’m using vmd 1.9.3 and it works well alone.

I compiled lammps with yes-user-molfile, and there is no error in compiling and using other commands. ( I didn’t change /lib/molfile/Makefile.lammps )

I tried to assign plugin path in dump command (dump 1 all molfile 1000 test.pdb pdb .:/usr/local/lib/plugins/vmd/plugins/LINUXAMD64/molfile ) but it doens’t work.

I also copied the files in /usr/local/lib/plugins/vmd/plugins/LINUXAMD64/molfile were copied to working directory but it doens’t work too.

(The files in /usr/local/lib/plugins/vmd/plugins/LINUXAMD64/molfile is as follows:

abinitplugin.so brixplugin.so dcdplugin.so fs4plugin.so jsplugin.so molemeshplugin.so pbeqplugin.so psfplugin.so uhbdplugin.so vaspxmlplugin.so

avsplugin.so carplugin.so dlpolyplugin.so gamessplugin.so lammpsplugin.so msmsplugin.so pdbplugin.so raster3dplugin.so vasp5xdatcarplugin.so vtfplugin.so

babelplugin.so ccp4plugin.so dmsplugin.so graspplugin.so maeffplugin.so namdbinplugin.so pdbxplugin.so rst7plugin.so vaspchgcarplugin.so vtkplugin.so

basissetplugin.so corplugin.so dsn6plugin.so grdplugin.so mapplugin.so netcdfplugin.so phiplugin.so situsplugin.so vaspoutcarplugin.so webpdbplugin.so

bgfplugin.so cpmdplugin.so dtrplugin.so gridplugin.so mdfplugin.so offplugin.so pltplugin.so spiderplugin.so vaspparchgplugin.so xbgfplugin.so

binposplugin.so crdplugin.so dxplugin.so gromacsplugin.so mol2plugin.so parm7plugin.so plyplugin.so stlplugin.so vaspposcarplugin.so xsfplugin.so

biomoccaplugin.so cubeplugin.so edmplugin.so hoomdplugin.so moldenplugin.so parmplugin.so pqrplugin.so tinkerplugin.so vaspxdatcarplugin.so xyzplugin.so

)

I also tried to change /lib/molfile/Makefile.lammps as

molfile_SYSINC = /usr/local/lib/vmd/plugins/include/molfile_plugin.h

molfile_SYSPATH = -Ldir

and it compiles well, but the command doesn’t work again.

I’m not good at linux, so I couldn’t figure it out what causes the error, vmd plugins or lammps.
Could you tell me what is the problem?
I really look forward to your reply.

Best regards,
Kihoon Bang.