I am a new lammps user. I have installed it in my macOS following the commands given in the website. Now I don’t know how to run the input script in the terminal. My file name is “in.test”, I have tried the commands ‘mpirun lammps<in.flow’ , ‘lmp_mac<in.test’ and ‘lammps<in.test’ and still i cannot run my input script. How should I run the file. Help me please.



You need four things to run a lammps or any MD simulation successfully.

1.) input structure (either externally created readable by lammps or defined on-the fly via the input script)

2.) Forcefield file (using pair_style e.g., eam/alloy)

3.) lammps input file (in your case ‘in.test’)

4.) lammps executable (after successful compilation e.g., ‘lmp_mpi’ in /src/ directory) or download the executable directly (

Assuming that you have all the prerequisite files in the same directory (at least just to start with!).

try this command:

mpirun -np 4 ./lmp_mpi -in in.test

I used 4 processors in the above command. you could also try with different number of processors supported by your hardware. But make sure you use consistent definition in the input script using “processors 2 2 1” (e.g., for 4 processors).

I am using LAMMPS (16 Mar 2018) version. Also make sure that your ‘in.test’ file is complete and error free.

Good luck,