How to use the vcsgc plugin in the windows environment (lammps)

The version of lammps in windows environment has many updated plugins like LAMMPS-USER-VCSGC-plugin-23Jun2022-update2-MPI.exe, I have installed this plugin but I don’t know how to use it, when I run the VCSGC related in file, the error shows “Unrecognized fix style ‘sgcmc’”.

how should I use this plugin in windows environment, thanks.

What specific version of LAMMPS do you have installed?

I cannot test this specific version on my test machine since I have currently a different MPI version installed and am making tests with that (LAMMPS Windows Installer Packages with support for MS-MPI - Testers needed).

But for the non-MPI version I see the following:

LAMMPS Shell version 1.2  OS: Windows 11 21H2, Windows ABI 6.2 (9200) on x86_64
MinGW-w64 64bit 9.0 / GNU C++ 11.2.1 20210728 (Fedora MinGW 11.2.1-3.fc35) with OpenMP 4.5
LAMMPS (23 Jun 2022 - Update 2)
  using 2 OpenMP thread(s) per MPI task
Loaded 1 plugins from C:\Users\akohl\AppData\Local\LAMMPS 64-bit 23Jun2022\plugins
Loaded 1 plugins from C:\Users\akohl\AppData\Local\LAMMPS USER-VCSGC Plugin 23Jun2022
LAMMPS Shell> plugin list
Currently loaded plugins
   1: command style plugin hello
   2: fix style plugin sgcmc

Which confirms the plugin is loaded by default and the sgcmc fix is available.
Of course, this will only happen when the LAMMPS version and the plugin version match exactly.

Thank you very much for your prompt reply, my lammps folder shows LAMMPS 64-bit 17Feb2022-MPI.

You have to uninstall that version and install the exact same LAMMPS version as the plugin is compiled for.

Your reply was very valuable to me, thank you very much!

I re-downloaded the lammps and plugin versions, and the following is the plugin list shown in my new version

LAMMPS Shell> plugin list
Currently loaded plugins
1: command style plugin hello
2: fix style plugin sgcmc

When I run the sgcmc example (examples · master · materials-modeling / vcsgc-lammps · GitLab), the program runs as: mpiexec -np 16 lmp -in example_input_", but still the same problem occurs, i.e., Unrecognized fix style ‘sgcmc’.

Also, there is a ‘’ in the plugin folder in the lammps path,

Should the downloaded ‘’ be associated to the plugin folder by some means? After all, the above test result is obtained after directly installing LAMMPS-USER-VCSGC-plugin-23Jun2022-MPI.exe

What is the complete output of the command?

No. The installer will update the LAMMPS_PLUGIN_PATH environment variable as needed.

It works for me. Please note that the input you are using is not large enough for a parallel run, but that should result in a different error after about 100 MD steps.