install LAMMPS GPU based on ubuntu 16.04 desktop version

Firstly, I’m not a prof. It will require certain sacrifice before I can even dream of being called a doctor, let alone a professor :frowning:

Secondly, you can installing CUDA 9.2 by switching to compatible gcc - this is not exactly tied to Ubuntu version (see CUDA 9.2 support gcc up to 6.x, so the default in 18.04 (I believe it comes with gcc-7.3.0) won’t work. You just need to use the hack there to downgrade your gcc when compiling and installing your CUDA 9.2.

OpenMPI and FFTW can be easily compiled once you have your gcc of choice. If you have different gcc backend, it is strongly recommended to compile openmpi yourself and not do sudo apt install openmpi (if that’s the correct name for the library).

Again, you should post your output errors so hints and suggestions can be given.

Installing OS, however, is beyond my helping capability.


Dear Quang Ha,

Thank you very much for you explanations.

I was installing OS successful. The system was crash due to my wrong procedure to install lammps GPU on ubuntu.

Now.I have installed cuda 9.0 +openmpi-1.8.2+31lammps17+fftw 3.4.4 based on Ubuntu 16.4.

It rund well with the lammps in.lj file (only cpu ) by the command line:

mpirun -np 8 lmp_31Mar17 **< in.ij**
**However, if I add the gpu package ,it shows error. Can  you figure out this error below ?**


**Thank you very much for any help.**
Best wishes
Liyi Bai