Installation error for AMSET

Hii,
I am trying to install “AMSET” using pip on ubuntu_18.04.5 lts but get the below error:
Could not find a version that satisfies the requirement quadpy==0.16.10 (from amset) (from versions: 0.16.15)
No matching distribution found for quadpy==0.16.10 (from amset).

How can I get rid of this error?
My python version is 3.6.
"