Installation problem: version Qt_5_PRIVATE_API not defined in file

Dear OVITO Devolopers, stukowski:

I am glad to try and use ovito in the linux system for some new user-defined modifiers. But I met a problem when I tried to installed it on the cluster (This cluster could not link to the website so I could not use the wget or sudo command). After I finished reading all the related information on the ovito forum and here, I realized I need your kind help.

My installed steps are listed as follows:

  1. Download the linux version of ovito from ovito website and upload it to the cluster via Xftp.

  2. Unzip it by the command:
    xz -d ovito-basic-3.3.4-x86_64.tar.xz
    gzip -xvf ovito-basic-3.3.4-x86_64.tar

  3. As I tried to run it by command: ovito, here comes the problem information:

qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: minimal, offscreen, vnc, xcb.


I tried some actions then.

  1. According to the link,, I cleared the DISPLAY environment variable prior to importing the OVITO module by command:
    export DISPLAY=

It didn’t work.

  1. I searched on line and checked with export QT_DEBUG_PLUGINS=1, I got following information:

It seems that the version is not that correct, then I checked the Qt version:

$which qmake
$qmake -version
QMake version 3.1
Using Qt version 5.9.6 in /vol6/software/anaconda3-5.3.0/lib

The Qt version here is Qt. 5.9.6, while I checked the folder $home/software/ovito-basic-3.0.1-x86_64/lib/ovito, their versions might be much higher.

  1. I could not think of any better ideas. Then I reinstalled a lower version of ovito: ovito-2.9.0-x86_64.tar in the same way. I got such results:

The Qt version is much lower. I was really confused now. I write some commands in the ~/.bashrc file:

export PATH={HOME}/software/ovito-2.9.0-x86_64/bin:{PATH}
export OVITOS_BIN=$HOME/software/ovito-2.9.0-x86_64/bin

I might write too much details, only to make sure my problem was clearly understood. Could you please help you install ovito correctly and run it normally?

Thank you!