Issue during installation due to grep

Hi,

I just figured this issue should be written down somewhere as it’s fairly random and hard to isolate. When installing lammps by (a) downloading, (b) cd to src and © running make (using whichever makefile you setup) you might get an error such as the following truncated output:

Hi,

    I just figured this issue should be written down somewhere as it's
fairly random and hard to isolate. When installing lammps by (a)
downloading, (b) cd to src and (c) running make (using whichever makefile
you setup) you might get an error such as the following truncated output:

thanks for the report and the suggestion for a workaround. would you
mind telling us, what OS and version this is on?

my Fedora Linux box here has colorized grep as well, but it is
realized using an alias and thus doesn't affect scripts.

axel.

I’m on a CentOS system using the gnome terminal for the LAMMPS July 30th, 2016 version (though I’ve found the same error on the 7Dec15th and 14May16 versions as well).

More OS info from cat /proc/version is:

Linux version 2.6.32-573.12.1.el6.x86_64 ([email protected]…6336…) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-16) (GCC) ) #1 SMP Tue Dec 15 21:19:08 UTC 2015

finally, the grep colorization is set through the .zshrc file using the export command previously stated.

Henry

I'm on a CentOS system using the gnome terminal for the LAMMPS July 30th,
2016 version (though I've found the same error on the 7Dec15th and 14May16
versions as well).

More OS info from cat /proc/version is:

Linux version 2.6.32-573.12.1.el6.x86_64
([email protected]) (gcc version 4.4.7 20120313 (Red Hat
4.4.7-16) (GCC) ) #1 SMP Tue Dec 15 21:19:08 UTC 2015

finally, the grep colorization is set through the .zshrc file using the
export command previously stated.

thanks,

please consider undoing this customization and realizing the grep
colorization through using an alias instead (this for bash but should
work with zsh as well):

alias grep='grep --color=auto'

strictly speaking this is not really a LAMMPS problem, but a bad idea
for a feature in grep (changing default behavior of a standard shell
command through a custom environment variable, that is).
your setting is likely to break other shell scripts, too. but since it
is easy to protect LAMMPS' shell scripts against it, it is probably a
good idea to do anyway (same goes for setting the C locale).

axel.