Issue loading search results from Norway


We are unable to explore any materials from the web page. When we enter in to the materials explorer/search page the water molecule is always rotating. This problem is happened not only for me all people in Norway. Could you please fix this problem?


Welcome @vajeeston,

Thanks for letting us know. We’re aware Materials Project is slower the further you get from California … for some technical information, we use Cloudflare as a global ‘content delivery network’ and will soon be deploying web instances on AWS to make the website faster worldwide.

That said, there should be no reason it shouldn’t load at all, even if it’s slow. We have “health checks” worldwide, and they’re currently reporting healthy in Europe.

Can you double check your ad/content blockers, web browser, etc?



Hi Matt:

I have the same issue as @vajeeston; the water molecule just keeps rotating after logging in. I left it rotating last night and this morning it still kept turning around…

I have tried to use the latest versions of Firefox, Edge, and Chrome on Windows 10. I have used two different IP addresses, both in Norway. I have tried to login using my email address and my GitHub account. I did not notice any ad/content blocker that should have made any trouble.

I have used MaterialsProject for several years without problem. This issue appeared some time during this summer and I have not been able to login after that.

I appreciate your support and hope it will be possible to resolve this issue.

Best regards,

Ok, thanks as well @olem! This is useful.

It’s not obvious to us what may be causing this so we’ll have to investigate.

@olem, @vajeeston, if it’s ok could you send me a private email at [email protected] with the email addresses you used to log-in to Materials Project? If you’d be willing to share an IP address used to connect, that might also be useful.

I’d really like to figure this out, but it might require some manual examination of our logs.

same issue from UK I have tried to use the latest versions of Firefox, Edge, and Chrome on Windows 10 but the problem still exist

This should now be fixed, it was ultimately down to our internal firewall inadvertently blocking some of the IPs used by Cloudflare, which is why it was only affecting certain regions.

Thanks all again for reporting and to @shreddd for tracking this down, there should be a longer-term fix in place this week to prevent the firewall from blocking these IPs again in future.

@naeem_eshawish if this is still affecting yourself, or if this is affecting anyone else, please let us know.

1 Like