kokkos_cuda illegal memory access

A student I am working with (Jonathan, cc'd) is getting an exception
when using kokkos_cuda to do som GB energy calculations. We are using
CUDA 7.0.28 and g++ 4.9.2. The system has 2 NVIDIA K80 cards, each
card having two gpus.

The input file references some other files - what's the best way to
provide those here? Attach with a zip or something?

Let us know what further information is needed. It may be helpful, so
here is the output from GDB (using one task, one thread, one gpu):

LAMMPS (10 Aug 2015)
KOKKOS mode is enabled (../lammps.cpp:492)
  using 1 OpenMP thread(s) per MPI task
  using 1 OpenMP thread(s) per MPI task
Reading data file ...
  triclinic box = (0 0 -102.686) to (37.8843 38.4217 112.955) with
tilt (15.1537 22.7306 0)
WARNING: Triclinic box skew is large (../domain.cpp:181)
  1 by 1 by 1 MPI processor grid
  reading atoms ...
  18880 atoms
8160 atoms in group atomsA
9080 atoms in group atomsB
0 atoms in group atomsC
820 atoms in group bottom
820 atoms in group top
17240 atoms in group mobile
WARNING: Resetting reneighboring criteria during minimization (../min.cpp:168)
Neighbor list info ...
  1 neighbor list requests
  update every 1 steps, delay 0 steps, check yes
  master list distance cutoff = 8.28721
  ghost atom cutoff = 8.28721
Setting up cg style minimization ...
  Unit style: metal
WARNING: Fixes cannot send data in Kokkos communication, switching to
classic communication (../comm_kokkos.cpp:368)
terminate called after throwing an instance of 'std::runtime_error'
  what(): cudaDeviceSynchronize() error( cudaErrorIllegalAddress): an
illegal memory access was encountered
Traceback functionality not available

[New Thread 0x7fffeea17700 (LWP 67491)]
[New Thread 0x7ffff27d0700 (LWP 67483)]

Program received signal SIGABRT, Aborted.
0x00007ffff4be0625 in raise () from /lib64/libc.so.6

Kokkos is still under active development, so thank you for bringing this up to our attention.

It seems that you are starting your run with a minimization, which Kokkos does not yet support. So it is suggested you run minimization without Kokkos, which is going to be faster anyway. That said, it worked for me to perform a minimize before a run. Which pair_style are your using? The error indicates that GPUs are trying to access host memory space, which is not allowed.