kokkos cuda segfault

It looks like the error is from CommKokkos in MPI. Kokkos cuda
requires GPUDirect (aka CUDA-aware MPI). See
http://keeneland.gatech.edu/software/gpudirect. Do you know if that is
enabled for your MPI? For a new enough version of OpenMPI, it is on by
default, and you have to configure MVAPICH2 with --enable-cuda and
setting the environment variable MV2_USE_CUDA to 1 during runtime, but
I don't know what it takes to enable that for SGI.

Also, are you using the latest version of Kokkos? Since Kokkos is
under active development, I would highly recommend using the
development (latest daily build) version of LAMMPS when using the
Kokkos package. There could be bugs or other issues in the
older/stable versions that have already been fixed in the development

Thanks for the help Stan. It looks like SGI doesn’t require any special flags to be cuda-aware. The segfault issue was resolved by compiling on a GPU node. My pervious compiles were performed on a regular sandy bridge node, which I think were missing some libraries.