Lammps 23June 2022


I am a new useer to lammps.
I am running lammps -kokkos-gpu of lammps-23Jun2022 (stable version).
When I tried to run a beadspring system using a restart data file I get below error;
" Unrecognized bond style ‘fene/omp’ is part of the OPENMP package which is not enabled in this LAMMPS binary. (src/force.cpp:382)"
Please advice.


First a general remark.

As described in the documentation, binary restart files are not portable between different LAMMPS versions or executables with different compilation settings.
Data files, on the other hand, are more portable and can, if needed, be adjusted with a text editor.

So you must first convert the restart file with the LAMMPS binary that created it to a data file and then use that data file to start a simulation with the new executable.

The error message itself is rather self-explanatory: the run from which the restart was created used the OPENMP package, but your current executable does not have it enabled.

I tried to run a data file that was created from a restart file.
That gave me the same error.

Then the error is in your input. You are using a style that is not available in your executable.