LAMMPS_CUDA Precision

Hello,

I installed the August 25, 2011 version of LAMMPS (all packages) on our cluster. When I run LAMMPS however, I get these warnings about the
difference in precision of the cuda vs. cpp code.

LAMMPS (25 Aug 2011)

Using LAMMPS_CUDA

CUDA WARNING: Compile Settings of cuda and cpp code differ!

CUDA WARNING: Global Precision: cuda 0 cpp 2

CUDA WARNING: Compile Settings of cuda and cpp code differ!

CUDA WARNING: X Precision: cuda 0 cpp 2

I have set the precision to double when I built the libraries in the Makefiles under user-cuda and gpu. Not sure what “0” precision means. Is there a setting
within the LAMMPS /src directory that I might have overlooked?

Thanks

Akila

Hi

in principal this should not happen (this is a really helpfull answer isnt it?). What you can do is go to lib/cuda and do a "make clean" followed by "make -j 8".
Then go to the src directory and delete the files in "Obj_MACHINENAME" and compile again with "make MACHINENAME -j 8".
Let me know if that works.

Cheers
Christian

-------- Original-Nachricht --------

Hello Christian,

Thanks, that did the trick I believe! I also included the CUDA PRECISION and CUDA FFT flags in the Makefile under the src directory as I was getting
the following error message with one of the examples (in.phosphate.gpu under examples/cuda directory):

ERROR: Using kspace_style pppm/cuda without cufft is not possible. Compile with cufft=1 to include cufft

I no longer get this error but for the example, “in.phosphate.gpu” under the examples/gpu directory, I get

ERROR: Invalid kspace style

Should this really be:

kspace_style pppm/gpu 1e-5

and NOT

kspace_style pppm/gpu/ 1e-5

in the input file as using the former does not return an error.

Akila

Hello Christian,
Thanks, that did the trick I believe! I also included the CUDA PRECISION and
CUDA FFT flags in the Makefile under the src directory as I was getting
the following error message with one of the examples (in.phosphate.gpu under
examples/cuda directory):
ERROR: Using kspace_style pppm/cuda without cufft is not possible. Compile
with cufft=1 to include cufft
I no longer get this error but for the example, "in.phosphate.gpu" under the
examples/gpu directory, I get
ERROR: Invalid kspace style
Should this really be:
kspace_style pppm/gpu 1e-5

no. you cannot mix the GPU package and the USER-CUDA package.

axel.

Axel,

I think I might have confused you. Sorry.

I was using the in.phosphate.cuda under /examples/USER/cuda

which seems to be working fine.

However, in.phosphate.gpu under /examples/gpu is the one that gives me the error: Invalid kspace style.

It appears as the following in the input file:
kspace_style pppm/gpu/<precision> 1e-5

I did run lammps with -cuda off to use the gpu package and disable the USER-CUDA package.

Thanks
Akila

Axel,

I think I might have confused you. Sorry.

I was using the in.phosphate.cuda under /examples/USER/cuda

which seems to be working fine.

However, in.phosphate.gpu under /examples/gpu is the one that gives me the
error: Invalid kspace style.

It appears as the following in the input file:
kspace_style pppm/gpu/<precision> 1e-5

that has to be pppm/gpu 1.e-5

whether you use single or double precision
in pppm/gpu is now determined by the
precision you choose for the FFT library.

i guess the example has not been updated
since the single precision FFT code was
folded into the distribution.

axel.

Axel,

That's what I thought as I had mentioned in my first email, removing the precision made it work.

Thanks!
Akila