LAMMPS Mean squared displacement from rerun

Hi

I’m trying to calculate the msd time series for a fluid system from a previous run’s xyz file. I need to take the latter half of the xyz file, as this is the production data.
My problem is that the msd is not zero at timestep 0. I have tried indexing the dump file from within lammps using the “first” keyword, and also running from the beginning of a modified file containing only the latter half of the run. The original run used PBC’s, and so the xyz file contains wrapped coordinates and no image flags. I used the zero potential in my msd input script, as it will not be integrated, but the original run had a hybrid table/dipole potential. I have the com keyword set to yes and the average keyword set to no.

Is there an obvious issue here which is preventing me from recovering 0 msd at 0? Input script attached.

Thanks,
Cassandra

msd.in (761 Bytes)

Have you tried reading the first frame of the trajectory file with read_dump before defining the msd compute?

Without image flags, you will not get the expected results, though.

2 Likes

Thank you, this helped.