[lammps-users] AI-REBO

Hi All,

I have been trying to use the AI-REBO potential. I have written an input script which has a hybrid AI-REBO/EAM/LJ potential.

dimension 3
boundary p p p
units metal
atom_style atomic
newton on
read_data INPUT_LMP.dat

pair_style hybrid lj/cut 10.0 eam/fs airebo 3.0 1 1
pair_coeff * * airebo CH.airebo C C C
pair_coeff * * eam/fs Fe_mm.eam.fs NULL NULL Fe

When I run the script, the log file tells me:

“ERROR: Invalid pair style”

right after the line: “pair_style hybrid lj/cut 10.0 eam/fs airebo 3.0 1 1”.

I have used the eam/fs and lj/cut pair_styles in the past and had no problems. So, I am
pretty sure the reason for the error message is the AI-REBO potential. Is there anything that I am missing?

I found in the documentation that :

“This pair style is part of the “manybody” package. It is only enabled if LAMMPS was built with that package (which it is by default).”

However, I built LAMMPS (06/22/2007 version) in the default mode and so this should not be a problem.

It will be very helpful to have some input.

Soumik Banerjee.

Soumik Banerjee
Research Assistant
Multiscale Research Group
231 Norris Hall, Virginia Tech
Cell # (540) 921-7630

I ran this script with the current version of the code and it ran fine.