[lammps-users] Can not find -lifcore -lsvml -lompstub -limf error during compilation of lammps

Dear all

I want to compile lammps with meam and reax package in cygwin. when i am trying make cygwin, finally ending up with cannot find -lifcore -lsvml -lompstub -limf error.
can i give lgfortran instead of these four libraries?

Dear all
I want to compile lammps with meam and reax package in cygwin. when i am
trying make cygwin, finally ending up with cannot find -lifcore -lsvml
-lompstub -limf error.
can i give lgfortran instead of these four libraries?

yes. they are the intel compiler runtime libraries.
you need the equivalent for gcc and that would indeed be -lgfortran

axel.

thank you axel…
i have got the lmp_cygwin.exe file. but when i am trying to run example problem, it gives following error:
*** fatal error - cygheap base mismatch detected
this problem is probably due to using incompatible version of the cygwin DLL.

i am using the latest version 1.7.8 of cygwin1.dll.

what is the error?

thank you axel...
i have got the lmp_cygwin.exe file. but when i am trying to run example
problem, it gives following error:
*** fatal error - cygheap base mismatch detected
this problem is probably due to using incompatible version of the cygwin
DLL.
i am using the latest version 1.7.8 of cygwin1.dll.
what is the error?

it is for sure not a lammps error. go ask the cygwin folks.

axel