[lammps-users] cannot read input file...

Hi there,

I'm using Lammps for just 3 months, and always face some weird problem.
I usually submit my jobs on Lonestar at TACC(Texas Advanced Computing
Center).

As you all know Lammps is well parallelized. But whenever I request job
files with many processors (let's say, more than 12 processors), more than
70% cases, Lonestar could not read input file.

in log.lammps, only 1 line is written.

LAMMPS (9 Jan 2009)

However, when I submit job files with less than 4 processors, most of jobs
work well.

I don't know reason, just guess that parallelizing in lammps have some weak
point. Does any one of you have such a problem? Or if you guys know how to
solve this matter, plz let me know.

It might be a problem at TACC side instead of LAMMPS.
I have a similar situation. With same lammps and the same input file worked in March, at TACC (Ranger), I couldn’t get it run now. After I submitted the job, the system lauches lammps several times, as shown below.
You can write to help@teragrid.org and see whether there is a solution.

TACC: Done.
TACC: Starting up job 705247
TACC: Setting up parallel environment for MVAPICH ssh-based mpirun.
TACC: Setup complete. Running job script.
TACC: starting parallel tasks…
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)
LAMMPS (9 Jan 2009)

It might be a problem at TACC side instead of LAMMPS.
I have a similar situation. With same lammps and the same input file
worked in March, at TACC (Ranger), I couldn't get it run now. After I
submitted the job, the system lauches lammps several times, as shown
below.

the output below indicates, that you have a serial not a parallel
binary. check your compilation. if the TACC staff compiled that
binary complain to them.

in the other case (job starting but not running), a common problem
is that parallel environments not always forward standard input
to all nodes or turn it from line buffered to block buffered.
the resolution here is to use the -in flag and _not_ redirection
via '<'.

HTH,
   axel.