[lammps-users] compiler optimization + coulombic tabling


Chris Lorenz found that using a compiler setting with -O3 on his cluster
in Iowa breaks the coulombic tabling in a way that is hard to detect ---
it seems to work, but then crashes. There are a few ways around this:

1) turn the tabling off using "pair_modify table 0"
2) use -O2 instead of -O3
3) use the flag '-fno-strict-aliasing' with either -O2 or -O3 compiler
optimization settings

It seems that this problem is especially prevalent on 64 bit machines,
and only seems to happen when people use the -O3 compiler settings with
the coulombic tabling & bitmapping.