[lammps-users] compling and running problem for latest version of lammps

Hi, Axel,
I got the feedback from the support staff of the teragrid steele.
I’m wondering If the latest version of lammps works with mpich2 ? since mpich1 is no longer supported there. And I’m not sure if I can use the intel64 version, I remember you mentioned previously it is not necessary.
Thanks a lot.
Jihang

Hi, Axel,
I got the feedback from the support staff of the teragrid steele.

so what did this person say?

I'm wondering If the latest version of lammps works with mpich2 ? since

yes. LAMMPS only uses a small subset of the MPI-1 standard. this subset
is fully supported by mpich2.

mpich1 is no longer supported there. And I'm not sure if I can use the
intel64 version, I remember you mentioned previously it is not necessary.

it will just make things overly complicated upon linking. you can try.

cheers,
   axel.

I run with MPICH2 on my desktop box. It is backward
compatible to 1.1.

Steve