[lammps-users] dipole problems

I am having some problems with setting up a basic simulation with dipoles.

1. If my code is:
dimension 3
units lj
atom_style dipole

The output is
LAMMPS (1 Oct 2006)
ERROR: Invalid atom style

2. I next tried the below thinking dipole could only be used as a hybrid style:
dimension 3
units lj
atom_style hybrid charge dipole

This worked (atoms were created with both "charge dipole" and "dipole charge"), so I added the following:

variable x index 10
variable y index 10
variable z index 10
lattice fcc 0.85
region mybox block 0 $x 0 $y 0 $z
create_box 1 mybox
create_atoms 1
mass 1 1.0
velocity all create 1.0 46813 dist gaussian
dipole 1 2.0

pair_style dipole/cut 2.5 7.0

This produced the following output:
LAMMPS (1 Oct 2006)
Created box = (0 0 0) to (16.7577 16.7577 16.7577)
   1 by 1 by 1 processor grid
Created 4000 atoms
ERROR: Invalid pair style

Commenting out the 7.0 did not change the result. pair_style dipole/long also gave the same error. Are pair_style dipole/cut and dipole/long no longer supported? Does something special need to be specified when making LAMMPS to use dipole? I did not see anything about that in the documentation.

I am confused about the output I am created. Any suggestions explaining how to use dipole would be much appreciated.

Cheers,
Joyce

Joyce,

I’d recommend trying real units here too.

Paul

LAMMPS does not yet support point dipole simulations. We have some
test files for this but have not released them. Thus there are a few
places in the code where dipole stuff is computed, but there is no
way to invoke them with an input script.

Steve