[lammps-users] disordered data file


I have been running a two-step granular simulation with 2 separate input files. The first simulation I run with mpi and when using write_data, I get a data file that is disordered. That is, the atom ids are not in ascending order. I then call that data to my second simulation which I run in serial (have tried mpi too but to no avail) but it gives me a segmentation fault.

After a lot of trial and error debugging, I noticed that if my data file for the second simulation is in ascending order, it does seem to work. This is because I had done simulations where the first simulation is also run in serial which results in an ordered data file.

I don’t know what is going on here. Can anyone care to explain or provide an easy workaround without me having to write a script to correct the data file? I don’t see any mention of the data file being required to be written in ascending order in the docs.


The entries in data files can be in any order.

If the order makes a difference then that is either an indication of a more general problem in your simulation setup (that just doesn’t show up in the first case by chance) or a bug in the LAMMPS code.

Can you provide us with a (very) small input deck that can reproduce this behavior?

Please also test with the latest LAMMPS version. If this is a bug in the LAMMPS code, it may already have been fixed.