[lammps-users] DPD calculation stuck

Hi everybody,

I try to run a DPD simulation with 4 types of beads. There is an additional FENE potential for the beads of type 1 to model a polymer chain. (See input file)
The first step in the calculation consisted in relaxing the constrains due to the construction stage (I use chain.f given with the LAMMPS distribution). I use a pair_style soft potential and it works well.
Then I change the potential to DPD style (pair_style dpd 1 2.5 34567) and my calculation seems to be stuck. There is no error message or warning but nothing more happens.
I run this simulation in parallel (10 processors) using mpiexec and OpenPBS.
Do you have already met this kind of problem ? If yes, can you help me ?

I thank you ahead for your answers.

input2.dat (2.68 KB)


You'll probably need to do better, more thorough relaxation of the system. I think that the FENE bonds especially can be a bit difficult to relax. My guess is that when "nothing more happens" the simulation has probably already gone bad and is churning on NaNs or huge numbers or something. You might try dumping out thermo data more frequently so that you get a better feel for what is happening. You might also try running a small test version of your problem on 1 processor before trying it on a larger system in parallel. And you could try a smaller timestep that you gradually increase, use minimization, iterate between relaxation and dynamics, etc.


Thank you for your answer Paul,

I run the same simulation on 1 processor and it works (but is, of course, very slow) so I guess that there is something wrong with the communication between the processors when I run the same simulation in parallel. I will try to "debug" this problem by dumping thermo data every time step and also by reducing the time step.


Crozier, Paul S a �crit :