[lammps-users] Energy conservation with AIREBO

Dear Lammps-users,

I am just doing several test with the AIREBO potential and a small diamond lattice. I just create a 512 atom lattice and perform a dynamics in the NVE essemble without velocities rescaling. But the energy consevation is very bad and eventually LAMMPS lost atoms and the run is over.

I have tried with velocities rescaling and different time step but the behaivor seems the same. I also tried an energy minimization of the lattice and it seems right so i dont know where the problem is.

I apreciate any help! Thanks,

Diego Delgado

The input script is the following:

Diamond Lattice Test

units metal
boundary p p p

atom_style atomic
neighbor 0.3 bin
neigh_modify delay 5

create geometry

lattice diamond 3.57
region box1 block -7.14 7.14 -7.14 7.14 -7.14 7.14 units box
create_box 2 box1
create_atoms 1 region box1 units box

mass 1 12.0

Brenner potential

newton on
pair_style airebo 1.0 1 1
pair_coeff * * CH.airebo C H

initial velocities

compute calculo1 all temp
compute calculo2 all coord/atom 2.0
velocity all create 300.0 274878

fix 1 all nve
#fix 3 all temp/rescale 1000 300.0 300.0 5.0 1.0


timestep 0.0001
thermo 1
thermo_modify temp calculo1

dump 1 all xyz 25 dump.diamond
dump 2 all custom 5 dump.coord c_calculo2
run 10000

I ran your script (slightly modified, see attached), and it
runs fine on 8 procs. And this was with a 10x larger
timestep and 10x fewer timesteps. This is with the
current (fully patched) version of LAMMPS.

So I'm not seeing the problem you're describing.


in.bug (822 Bytes)