[lammps-users] "ERROR: Did not assign all atoms correctly"

Dear Lammps group:

I am currently running a simulation on four million atoms after testing on small scale systems.

When I run the simulation in our HP servers I got the following Error message:

ERROR: Did not assign all atoms correctly.

But with same input file I could run on my local machine.

Do we need to set any environment variables for running Lammps with large number of atoms.
Please help

Thank you,


LAMMPS should have no problem with 4M atoms, even on 1 proc.
The question to figure out is why it didn't assign the atoms to
a proc - usually this is b/c they are outside the simulation box and
you didn't specify a boundary condition correctly. Can you run this
on 1 proc? Or how many procs does it fail on? How are you generating
the atom positions? Are they all inside the simulation box?


Dear Prof. Plimpton:
The atom positions are actually from the restart file of a previous simulation. I did the following

  1. A system with 4M LJ atoms is subjected to melting and quenching in the first simulation with PBC in all the 3 directions. The final positions are written to a restart file. (see the attached quench.txt file)
  2. Using restart2data tool these are converted to a text (data) file
  3. In the next part I remove PBC in one of the direction and tried to conduct a deformation simulation by moving the boundary atoms with fixed velocity and setting the forces on them to be zero. (see the attached deform.txt file)

The error occured in the third step.

I have done similar simulations a number of times on small scale systems.
Even this simulation was running on a local workstation (Intel Xeon dual quadcore processer) albeit slowly.

The problem occurs only when I submit the Job in any of the cluster computers at our place, such as IBM p575 Power 5+, HP x86-64 Blade System.

Thank you,


deform.txt (1.23 KB)

quench.txt (1.02 KB)

When you read a data file without PBC then it's required that all atoms
be inside the box. I think at the upper boundary they have to be inside
the boundary, not on the boundary. So you can have round-off issues,
which might be different on different platforms. Try specifying slightly
larger box boundaries in your data file for the non-PBC boundary.