[lammps-users] Error Message " Domain too large for neighbor bins"

Hello everyone:

Last week , I ran NVT simulation for 144 atoms using a single processor . I ran for 100,000 timesteps, the simulation ran fine. I found a reasonable damping parameter.Currently I am running a NPT simulation for the same number of atoms. NPT conditions =300k and pressure =0bars, pdamp =0.1. I initially ran for 100,000 timesteps on 1 processor, however the job was terminated at 32000 steps. The error message I received is stated below

“lmp_Star:14566 terminated with signal 11 at PC=536a51 SP=7fbfffd190. Backtrace”

I lowered the pdamp value to 0.09, now the error message is “Domain too large for neighbor bins”. I am not too sure how to fix this problem. I used the default skin distance of 2.0 provided by lammps for the neighbor command. Can anyone assist me with this problem?

Format of Output file

units metal
boundary p p p
atom_style charge
pair_style hybrid/overlay buck 10.0 sw coul/long 10.0
kspace_style ewald 8.0

read_data data3.hamid
orthogonal box = (0 0 0) to (16.74 14.78 22.77)
1 by 1 by 1 processor grid
144 atoms
pair_coeff 1 1 buck 4369.01 0.29 0.0 5.5
pair_coeff 1 8 buck 4369.01 0.29 0.0 5.5
pair_coeff 2 2 buck 1171.52 0.29 0.0 5.5
pair_coeff 3 3 buck 452.5051 0.29 0.0 5.5
pair_coeff 6 6 buck 452.5051 0.29 0.0 5.5
pair_coeff 3 6 buck 452.5051 0.29 0.0 5.5
pair_coeff 7 7 buck 21.228 0.35 0.0 5.5
pair_coeff 8 8 buck 4369.01 0.29 0.0 5.5
pair_coeff 1 2 buck 1382.4811 0.29 0.0 5.5
pair_coeff 2 8 buck 1382.4811 0.29 0.0 5.5
pair_coeff 1 3 buck 3557.62 0.29 0.0 5.5
pair_coeff 1 6 buck 3557.62 0.29 0.0 5.5
pair_coeff 3 8 buck 3557.62 0.29 0.0 5.5
pair_coeff 6 8 buck 3557.62 0.29 0.0 5.5
pair_coeff 2 7 buck 430.6566 0.29 0.0 5.5
pair_coeff 2 3 buck 1848.7174 0.29 0.0 5.5
pair_coeff 6 7 buck 248.6324 0.29 0.0 5.5
pair_coeff 3 7 buck 248.6324 0.29 0.0 5.5
pair_coeff * * coul/long
pair_coeff * * sw SiOOO.sw NULL Si O NULL NULL NULL NULL NULL

neighbor 2.0 bin
neigh_modify delay 5

equilibrate

min_style cg
thermo 5
thermo_style custom step lx ly lz
minimize 1.0e-4 1.0e-6 120 1000
Ewald initialization …
G vector = 0.103808
vectors: actual 1d max = 0 -2147483648 -2147483648
Memory usage per processor = 3.51844e+13 Mbytes
Step Lx Ly Lz
0 16.74 14.78 22.77
5 16.74 14.78 22.77
7 16.74 14.78 22.77
Loop time of 0.0248649 on 1 procs for 7 steps with 144 atoms

Minimization stats:
Stopping criterion = energy tolerance
Energy initial, next-to-last, final =
-4099.54952324 -4231.36772167 -4231.51619502
Force two-norm initial, final = 127.971 33.0275
Force max component initial, final = 21.5803 5.74964
Final line search alpha, max atom move = 0.00013569 0.000780168
Iterations, force evaluations = 7 21

Pair time () = 0.0240731 (96.8156) Kspce time () = 5.17368e-05 (0.208072)
Neigh time () = 0 (0) Comm time () = 0.000520468 (2.09318)
Outpt time () = 1.00136e-05 (0.0402719) Other time () = 0.00020957 (0.842834)

Nlocal: 144 ave 144 max 144 min
Histogram: 1 0 0 0 0 0 0 0 0 0
Nghost: 2099 ave 2099 max 2099 min
Histogram: 1 0 0 0 0 0 0 0 0 0
Neighs: 12900 ave 12900 max 12900 min
Histogram: 1 0 0 0 0 0 0 0 0 0
FullNghs: 25800 ave 25800 max 25800 min
Histogram: 1 0 0 0 0 0 0 0 0 0

Total # of neighbors = 25800
Ave neighs/atom = 179.167
Neighbor list builds = 0
Dangerous builds = 0

300-NPT

velocity all create 300.0 5812775

fix 1 all npt 300.0 300.0 0.001 xyz 0.0 0.0 1.0 drag 1.0

fix 1 all npt 300 300 0.001 aniso 0.0 0.0 0.0 0.0 0.0 0.0 0.09
thermo 200
thermo_style custom step temp etotal press
thermo_modify flush yes
timestep 0.0001
run 100000
Ewald initialization …
G vector = 0.103808
vectors: actual 1d max = 0 -2147483648 -2147483648
Memory usage per processor = 3.51844e+13 Mbytes
Step Temp TotEng Press
7 300 -4225.9709 -9845.3832
200 305.31236 -4219.7988 8593.4767
400 296.33348 -4279.1396 -3136.6414
600 300.67251 -4308.4551 -9233.2729
800 299.01002 -4284.7804 4482.8603
1000 299.83777 -4269.7065 11694.432
1200 297.47747 -4299.2658 -3965.9411
1400 301.44018 -4301.9263 -293.11076
1600 298.91999 -4313.6304 -2490.9204
1800 301.88908 -4314.859 -3598.6121
2000 298.77294 -4308.8824 1856.1262
2200 308.06267 -4325.8125 -2941.8701
2400 0.082293505 -4413.0225 87622.221
2600 0.090123374 -4452.2817 -10144.745
2800 0.091723152 -4319.5728 -11660.254
3000 2.7249169 -4504.5926 -81281.119
3200 1.4441016e-05 -4321.3052 20736.807
3400 0.00019945601 -4212.1929 98612.497
3600 0.0032489983 -4466.7367 -55776.185
3800 0.56453887 -4596.3082 -51099.127
4000 0.012043746 -4037.4378 97998.002
4200 0.035817182 -4002.4483 136178.7
4400 0.16948562 -4243.8126 -31846.715
4600 1.6603359 -4342.3423 -113296.47
4800 233.75893 -4264.4707 -2686.2819
5000 421.0063 -4169.8963 106552.81
5200 44373.533 -5356.1305 -73249.315
ERROR: Domain too large for neighbor bins

Shanique Murray

2008/7/28 Shanique Murray <[email protected]…828…>

Hello everyone:

Last week , I ran NVT simulation for 144 atoms using a single processor . I ran for 100,000 timesteps, the simulation ran fine. I found a reasonable damping parameter.Currently I am running a NPT simulation for the same number of atoms. NPT conditions =300k and pressure =0bars, pdamp =0.1. I initially ran for 100,000 timesteps on 1 processor, however the job was terminated at 32000 steps. The error message I received is stated below

“lmp_Star:14566 terminated with signal 11 at PC=536a51 SP=7fbfffd190. Backtrace”

I lowered the pdamp value to 0.09, now the error message is “Domain too large for neighbor bins”. I am not too sure how to fix this problem. I used the default skin distance of 2.0 provided by lammps for the neighbor command. Can anyone assist me with this problem?

Format of Output file

units metal
boundary p p p
atom_style charge
pair_style hybrid/overlay buck 10.0 sw coul/long 10.0
kspace_style ewald 8.0

read_data data3.hamid
orthogonal box = (0 0 0) to (16.74 14.78 22.77)
1 by 1 by 1 processor grid
144 atoms

Shanique:

Your box is too small. The y-length is 14.78, while your neighbor list will consist of all particles within a radius of 12 A–which is the entire box, and then some. So this means that you’re going to end up double-counting a lot of atoms, which will throw your results off (and cause an error like that). You’ll probably need to either make your cutoff smaller or, more likely, make your box bigger.

–AEI

LAMMPS should do the right thing even if the cutoffs
are longer than the box length. You are getting the error
b/c the box is blowing up to a huge size. That could be b/c
of overlaps or something else unphysical in your system setup.
Or for that small a system possibly you are getting large pressure
fluctutations that are changing the volume rapidly. I'd monitor
the volume of the box and see it is behaving well. You might
have to play with the damping and drag parameters of fix npt.
You might also try fix press/berendsen - it tends to oscillate the
volume less.

Steve