[lammps-users] Errors making LAMMPS-- libcore.a, etc "not of required architecture"?

I am trying to make the latest version of LAMMPS (my file is lammps-10nov09) with the ReaxFF package on a Mac OSX machine and getting errors that my local unix experts can't help me with. I am using mpic++ as my compiler.

The default Mac makefile calls the "lifcore.a" system library but I do not have that library. When I try to make it like this anyway, I get an several warnings "file is not of required architecture." I have tried making it after changing the makefile to use "libifcore.a" which I do have in the directory that it is looking for lifcore in. Then I get the simple error "library is not found for -libifcore".

Any ideas on how I can solve this problem? Thanks

Luke Erickson

libfcore.a is a Intel compiler file. If you're not using that compiler then
you shouldn't be listing that library in your Makefile.mac. I assume
your''re not, so have you tried just deleting that entry from the Makefile.mac?