[lammps-users] floating except with fix rdf

i’ve tried running the 12 april release of LAMMPS and it seems to work fine until i try to use “fix rdf”. if i run LAMMPS on a single processor, i get a “Floating exception” before LAMMPS is able to output any rdfs. if i run LAMMPS in parallel using mpi, i get the error message:

p0_693: p4_error: interrupt SIGFPE: 8
Killed by signal 2.
p0_693: (2.923245) net_send: could not write to fd=5, errno = 32

i’ve compiled LAMMPS as is, without any of my own additions, and have tried running it on different machines, in parallel and serially, and with different input and data files and keep getting the same result.

however, i can’t see from the LAMMPS code why this might be happening.

i have no problems when i use the same input and data files with the 30 jan release of LAMMPS and, as far i can tell, i’m not using any commands for which the syntax has changed between the two releases.

any suggestions about what might be going wrong?



Could you send me your input script and data file so
that I can better see what is going on?



This was a bug - now fixed via a patch for 25Apr06.