[lammps-users] Hybrid w/Table works now, but not when R, rlo, rhi, specified

Can you use your table file by itself without error? I.e. not in a hybrid simulation?

Thanks Steve, I simplified my script (only using table, no hybrid command) and table file (only using N). I am getting hybrid and solo table simulations to work now, but only when I remove "R 0.00 2.53" from the 4th line in my table file (below).

# Johnson potential for FeC

ENTRY1
N 1000 R 0.00 2.53

1 0.002530 0.000000 0.000000
2 0.005060 0.000000 0.000000
...
1000 2.530000 0.000000 0.000000

From the Morse table example file in the LAMMPS doc online, it seems like line 4 of my table is ok. Everything is working satisfactorily, but I still would like to know why my line 4 is getting "ERROR: Invalid pair table cutoff"

Thanks, again
Nicholas J. Lee

2008/8/4 nicholas lee <[email protected]…114…>

Can you use your table file by itself without error? I.e. not in a hybrid simulation?

Thanks Steve, I simplified my script (only using table, no hybrid command) and table file (only using N). I am getting hybrid and solo table simulations to work now, but only when I remove “R 0.00 2.53” from the 4th line in my table file (below).

The error occurs because there’s a line in pair_table.cpp:

if (rlo <= 0.0) error->all(“Invalid pair table cutoff”);

which prevents you from setting the cutoff to 0.0.

–AEI