[lammps-users] install lammps on HPC

Dear developer
I have install lammps on a HPC cluster (OpenSuse Leap 15.2) in local mode using :

module load gcc/10.2 openmpi/4.1

cd lammps-8Apr21
mkdir build
cd build
cmake -C …/cmake/presets/most.cmake -C …/cmake/presets/nolib.cmake …/cmake (–> seul les packages sans appel de librairies externes seront installées)
cmake --build .

All seems to work fine. I have submitted a job on n cores using mpirun -n n ~lammps-8Arp21/build/lmp -in file.in

The job is running but on 1 core only

Attached are the CMakeError.log who seems to indicate that compiling using MPI failed
and the CMakeOutput.log

Thanks a lot for help.
Best
Pascal

SignatureGREMI.png

CMakeOutput.log (60.9 KB)

CMakeError.log (1.63 KB)

It looks like your MPI library was not detected.
you should check if you can compile a simple “hello, world” example for mpi with those environment modules loaded.
It would be more helpful to see the screen output from your “cmake” command and the output of ./lmp -h instead of the attached files.

axel.

SignatureGREMI.png

Dear Axel ,
Thanks a lot .

attached is the ./lmp -h > output_lmp-h file indicating tha MPI library has been detected.
So, I am just looking the slurm*.out and the current thermo line is repeated n times indicating the MPI paralelization is working
I apologize for not previously looking at the right place.
Best regards
Pascal

output_lmp-h (19.5 KB)

Dear Axel ,
Thanks a lot .

attached is the ./lmp -h > output_lmp-h file indicating tha MPI library has been detected.

no. on the contrary.

MPI v1.2: LAMMPS MPI STUBS for LAMMPS

means, that CMake did not detect a viable MPI library and is using the “fake” MPI library bundled with LAMMPS.

This should have been evident from the CMake configuration output to the screen.

So, I am just looking the slurm*.out and the current thermo line is repeated n times indicating the MPI paralelization is working

again, that is incorrect. it means that you are running n copies of a serial executable.

axel.

Dear Axel
I restarted the install in my local environment.
The HPC cluster is : 16 nodes 128 cores/node AMD EPYC 7702 2 GHz.

I did the following

[email protected]:~/lammps-8Apr21/build> module load cmake/3.20 gcc/10.2 openmpi/4.1
[email protected]:~/lammps-8Apr21/build> module list

Currently Loaded Modules:

  1. cmake/3.20 2) gcc/10.2 3) openmpi/4.1

Then
cmake -C …/cmake/presets/most.cmake -C …/cmake/presets/nolib.cmake …/cmake > output_cmake (this file is attached)

I have attached the cmake output in the file cmake_output (cmake -C …/cmake/presets/most.cmake -C …/cmake/presets/nolib.cmake …/cmake > output_cmake=

output_cmake (3.66 KB)

Yes, that looks correct so far.
The warning is from the new PLUGIN package that can only work with shared libraries enabled, but it does no harm otherwise.
Axel.

Dear Axel
hanks a lot
I have now compiled lammps using cmake --build .
It seems to work too. I have attached the output of ./lmp - h command
Thanks again for your help
Kind regards
Pascal

output_lmp-h (19.6 KB)